Page 1 of 1

SBC2: Debian package "Size mismatch" error

Posted: Mon Jan 07, 2019 1:44 am
by TestUzer
Tried to update/upgrade got an error of

Code: Select all

Failed to fetch http://www.phidgets.com/debian/pool/main/p/phidget22wwwjs/phidget22wwwjs_1.0.0.20190103-1+deb8_all.deb  Size mismatch


The update package list at
/var/lib/apt/lists/www.phidgets.com_debian_dists_wheezy_main_binary-armel_Packages says

Code: Select all

Package: phidget22wwwjs
Version: 99:1.0.0.20190103-1+deb8
Built-For-Profiles: debian8
Architecture: all
Maintainer: Patrick McNeil <patrick@phidgets.com>
Installed-Size: 2960
Homepage: http://www.phidgets.com
Priority: optional
Section: net
Filename: pool/main/p/phidget22wwwjs/phidget22wwwjs_1.0.0.20190103-1+deb8_all.deb
Size: 503406
SHA256: c34d3796808b39f315269acf320b832d4e2f311658ac0d6b8bb993df85275353
SHA1: 12ae000c39723bec1af0c8145c8783ef8a9c2b28
MD5sum: aa548a886b8e87813fd5081a0929aee8
Description: Phidgets WWW Interface for JavaScript



When looking at the repository http://www.phidgets.com/debian/pool/mai ... et22wwwjs/ it says

Code: Select all

phidget22wwwjs_1.0.0.20190103-1+deb8_all.deb 03-Jan-2019 19:13 503316


Forced it to install by editing the package list file with the actual size of 503316 bytes.

Checked if server runs on the SBC2 and executes commands from code on a PC.

Re: SBC2: Debian package "Size mismatch" error

Posted: Mon Jan 07, 2019 3:06 pm
by Patrick
Thanks for pointing this out, will be fixed today.

-Patrick