Issues under Windows 7 64-bit?

This forum is for the discussion of topics relating to third-party software that uses Phidgets.
pgaert

Issues under Windows 7 64-bit?

Postby pgaert » Thu Sep 16, 2010 5:39 am

VB.NET application, first user on Windows 7 64-bit is having trouble getting up and running. Phidgets driver appears to install OK, but running the app gets the following: "Unable to install or run the application. The application requires that assembly Phidget21.NET Version 2.1.6.284 be installed in the Global Assembly Cache (GAC) first."

I am not hardware-savvy... are there compatibility issues with Win7 64, a special process to install the Phidgets package, something my app needs to do but isn't? Any help would be greatly appreciated!

Thanks,
Paul

pgaert

Re: Issues under Windows 7 64-bit?

Postby pgaert » Fri Sep 17, 2010 4:26 pm

Any thoughts? Can anyone cofirm or deny that the Phidgets 21 Installer run under Win7 64-bit in fact installs in the GAC?

pgaert

Re: Issues under Windows 7 64-bit?

Postby pgaert » Mon Sep 20, 2010 7:33 am

Anyone at all?

AdamS

Re: Issues under Windows 7 64-bit?

Postby AdamS » Mon Sep 20, 2010 10:29 am

I believe that the windows installer, irregardless of architecture, installs the .NET libraries in the GAC.

What I think that error is really saying though however is that it is looking for the specific version of the Phidget21.NET libraries (2.1.6.284) in the GAC. Your installer is most likely installing a different version of the Phidget21.NET libraries in the GAC.

The problem here is that the VisualBasic.NET application you are using was developed such that the reference to the Phidget21.NET libraries was to look for a specific version, which can be modified to be version independent in the reference properties.

User avatar
Patrick
Lead Developer
Posts: 3155
Joined: Mon Jun 20, 2005 8:46 am
Location: Canada
Contact:

Re: Issues under Windows 7 64-bit?

Postby Patrick » Mon Sep 20, 2010 10:43 am

It actually doesn't matter if the version matches exactly - but the fist three digits need to match. Your software is looking for 2.1.6.x and the current version is 2.1.7.x. You need to either install an older version, or update your reference to phidget21.net and recompile your app.

-Patrick


Return to “Third-Party Software”

Who is online

Users browsing this forum: No registered users and 0 guests