Rasberry Pi 4 Artisan Temp not displaying

Supporting 2.6 and up
Carloanwar
Fresh meat
Posts: 1
Joined: Sat Mar 13, 2021 8:31 pm
Contact:

Rasberry Pi 4 Artisan Temp not displaying

Postby Carloanwar » Sat Mar 13, 2021 8:37 pm

I have no idea where to start I ran the HelloWorld command It stated Thermocouple 4X and it have me a serial #. It didn't say anything regarding the probes though. I may have accidentally installed the v21 drivers and v22 drivers. I don't know if that makes a difference or not. Running artisan 2.4.4. I have zero issues on with artisan reading the phidgets on my laptop, somehow it don't know where to start to copy some code that at least let's me see if the probes temperatures are being seeing within the Pi. I hooked it up to a powered USB, just in case. Help is really appreciated, I have exhausted my very limited knowledge of Linux or coding.

User avatar
mparadis
Site Admin
Posts: 790
Joined: Fri Oct 28, 2011 12:17 pm
Contact:

Re: Rasberry Pi 4 Artisan Temp not displaying

Postby mparadis » Mon Mar 15, 2021 9:45 am

If you want to test if your Phidgets are working on the Raspberry Pi, I would recommend setting up python for Linux and running the python example for your device (go to the product page for your device and see the "code samples" tab.

If the thermocouple is connected and working, this example will print the thermocouple temperature to the screen until you press a key. If you don't have a screen and keyboard attached to the Pi, you'll have to remote in using SSH to run the example.

As for the drivers, it's ok to have both Phidget21 and Phidget22 installed at the same time.


Return to “Linux”

Who is online

Users browsing this forum: No registered users and 3 guests